Les formules et macros indispensables pour bien utiliser Excel

Sur cette page, je répertorie toutes les formules et macros incontournables à connaître pour bien maîtriser Microsoft Excel (les formules fonctionnent aussi sur Google Sheets). Ces formules permettent de gagner du temps et augmentent considérablement la productivité.

Comment supprimer les espaces dans une plage de cellules ?

Cette macro permet de supprimer les espaces avant et après le contenu d’une cellule. Pour l’utiliser il faut selectionner la plage de cellule concernée et l’éxecuter à partir du menu macro sous Excel.

Code :

Option Explicit

Sub Supprimer_Espace()
 Dim cell As Range
 For Each cell In Selection
  cell.Value = Trim(cell.Value)
 Next cell
End Sub

Comment compter le nombre d’occurence dans une chaîne de caractères ?

Pour compter le nombre d’occurence d’un mot par exemple dans une plage de données, il faut utiliser la fonction NB.SI() qui se construit de la manière suivante :

=NB.SI(plage; critère)

 Exemple :

=NB.SI(A1:A100; "mot recherché")

Comment mettre en minuscule le contenu d’une cellule sous Excel ?

Pour mettre un texte en minuscule sous Excel, il faut faire appel à la formule MINUSCULE(). Cette formule permet de mettre un texte en minuscule à partir d’une texte en majuscule. Elle se construit de la façon suivante : =

=MINUSCULE(texte)

Exemple :

=MINUSCULE("BONJOUR LE MONDE")

Comment mettre en majuscule un texte ?

Pour mettre en majuscule le contenu d’une cellule sous Excel, il faut utiliser la formule MAJUSCULE(). Elle permet de mettre en majuscule une chaîne de caractère ou la référence à une cellule. Elle se construit de cette façon :

=MAJUSCULE(texte)

Exemple :

=MAJUSCULE("bonjour le monde")

Comment calculer l’âge à partir d’une date de naissance ?

Dans ce tutoriel, je vais vous donner une méthode pour calculer un age à partir de la date de naissance. Il suffit de calculer la différence entre la date du jour à l’aide de la fonction AUJOURDHUI() avec la date de naissance. Le résultat obtenu est au format date, il suffit de lui appliquer un format personnalisé. Dans la boite de dialogue « format personnalisé » saisissez le format suivant « aa » qui revient à demander d’afficher une date en années.

Comment afficher le jour de la semaine correspondant à une date ?

Pour afficher le jour de la semaine correspond à la date du 25/01/1980 par exemple, il faut appliquer un format personnalisé à la cellule qui contient la date :

  1. sélectionner la cellule contenant la date au format jj/mm/aaaa ou autre format
  2. aller dans le menu Format
  3. aller dans le sous menu Cellule
  4. dans la boite de dialogue Format cellule, choisir la catégorie Personnalisée
  5. dans Type, saisir « jjjj »

Cette manipulation aura pour but d’afficher le jour de la semaine. Dans notre exemple, ça affichera « vendredi ».

Comment compter le nombre de mots dans une cellule ?

Il n’existe pas de formule sous Excel pour compter directement le nombre de mots comme la formule NBCAR() qui permet de compter le nombre de caractère dans une chaîne de caractères. Pour compter le nombre de mots dans une cellule, on va avoir recours à plusieurs formules :

  • NBCAR()
  • SUPPRESPACE()
  • SUBSTITUE()

Par exemple : Dans la cellule A1, nous avons le texte « Bonne journée à tous ». Dans la cellule A2 nous écrirons la formule suivante :

=NBCAR(SUPPRESPACE(A1))-NBCAR(SUBSTITUE(SUPPRESPACE(A1); " "; ""))+1

Le résultat est 4 et il y’a bien 4 mots dans la phrase « Bonne journée à tous ».

Comment utiliser la fonction RECHERCHEV pour effectuer une recherche ?

La fonction RECHERCHEV() permet de chercher une valeur donnée dans la colonne située à l’extrême gauche d’une matrice et renvoie une valeur dans la même ligne d’une colonne que vous
spécifiez dans la matrice. La fonction RECHERCHEV() se construit de la manière suivante :

=RECHERCHEV(valeur_cherchée; table_matrice; no_index_col; valeur_proche)

valeur_cherchée : est la valeur à trouver dans la première colonne
de la matrice. L’argument valeur_cherchée peut être une valeur, une
référence ou une chaîne de texte.

table_matrice : est la table de données dans laquelle est exécutée
la recherche de la valeur. Utilisez une référence à une plage ou un nom de
plage.

no_index_col : est le numéro de la colonne de l’argument
table_matrice dont la valeur correspondante doit être renvoyée.

valeur_proche : représente une valeur logique indiquant si vous
souhaitez que la fonction RECHERCHEV() recherche une valeur exacte ou voisine de
celle que vous avez spécifiée
. Si cet argument est VRAI ou omis, une donnée
proche est renvoyée. En d’autres termes, si aucune valeur exacte n’est trouvée,
la valeur immédiatement inférieure à valeur_cherchée est renvoyée. Si
valeur_proche est FAUX, la fonction RECHERCHEV() renvoie exactement la valeur
recherchée. Si aucune valeur ne correspond, la valeur d’erreur #N/A est
renvoyée.

Comment utiliser la fonction SI sous Excel ?

La fonction SI() est une fonction logique. Elle permet de faire un test logique. Elle se construit de cette façon :

=SI(test; valeur si vrai; valeur si faux).

Exemple :

=SI(A1=10; "VRAI"; "FAUX")