La fonction NB.SI dans Google Sheets

Dans Google Sheets, la fonction NB.SI est utilisée pour compter des d’éléments dans une plage de cellules qui respectent une condition donnée.

On peut par exemple utiliser la fonction NB.SI pour compter le nombre de salariés qui perçoivent un salaire mensuel supérieur à 2000 euros.

Dans ce cas, on utilisera la fonction NB.SI et on lui demandera de nous retourner le nombre de salariés dont le salaire mensuel est supérieur ou égal à 2000 euros.

Comment utiliser la fonction NB.SI dans Google Sheets ?

La fonction NB.SI est une fonction qui se construit de la manière suivante :

=NB.SI(plage de cellules; critère)

Exemple : = NB.SI(A2:A30; “>=2000”)

Paramètres de la fonction :

Plage de cellules : Il s’agit de la plage des cellules sur lesquelles la fonction va réaliser le test spécifié dans le paramètre du critère.

Critère : Il s’agit du critère du test à réaliser. Toutes les cellules de la plage seront testées en fonction de ce critère.

Exemple de critères :

  • “admis” (avec les guillemets) : la valeur de la cellule est une chaîne de caractères
  • “=20” (avec les guillemets) : la valeur de la cellule est 20
  • “>10” (avec les guillemets) : la valeur de la cellule est supérieure à 10
  • “>=10” (avec les guillemets) : la valeur de la cellule est supérieure ou égale à 10
  • “<10” (avec les guillemets) : la valeur de la cellule est inférieure à 10
  • “<=10” (avec les guillemets) : la valeur de la cellule est inférieure ou égale à 10
  • B2 : référence à une cellule qui contient le critère à vérifier

Note : La fonction NB.SI ne peut vérifier qu’un seul critère à la fois. Si vous devez vérifier plusieurs critères, alors, il faudra avoir recours à la fonction NB.SI.ENS.

Exemple : Utiliser la fonction NB.SI

Dans cet exemple, nous allons voir comment utiliser la fonction NB.SI pour compter le nombre de salariés d’une entreprise qui perçoivent un salaire mensuel supérieur ou égal à 2000 euros. Cela peut être utile lorsqu’on travaille sur la masse salariale dans un service des ressources humaines.

  1. Sélectionner la cellule dans laquelle afficher le résultat de la fonction
  2. Saisir la formule =NB.SI(B2:B7;”>=2000″)
  3. Appuyer sur la touche Entrée du clavier pour valider

Explications : 

  • B2:B7 est la plage des cellules qui contient les valeurs à vérifier, ici, les salaires des employés
  • “>=2000” est la condition à vérifier, ici, supérieur ou égal à 2000 euros

Conclusion

La fonction NB.SI, comme la fonction SI et la fonction RECHERCHEV, figure parmi les fonctions indispensables et les plus utilisées dans Google Sheets et dans Excel.

Si vous débutez votre formation, empressez de maîtriser ces formules car elles vous seront toujours utiles.

Cette fonction permet de compter un nombre d’éléments d’une plage de cellules qui respecte un critère donnée. Pour aller plus loin dans votre formation, consultez :